RuneStorm
http://www.runestorm.com/forums/

Mouse "inertia" issue in VCD on Mac
http://www.runestorm.com/forums/viewtopic.php?f=114&t=79876
Page 1 of 1

Author:  janitowl [ Sat Nov 24, 2018 8:11 am ]
Post subject:  Mouse "inertia" issue in VCD on Mac

Hey,

I've gotten this recently but found that the controls are so wonky it's basically not playable. Despite the description, this happens with both mouse and touchpad, no difference.

When I move the pointer, it will show extreme inertia: basically it doesn't move for a second or a few seconds, and then continues to move in the direction even after I've stopped moving the mouse. This makes it very hard to even select the "Options" field in the menu and the game itself (having the exact same issue) gets *a lot* more fiddly.

I've thought it might be a performance issue, but
a) it happens also in the menu
b) closing all other programs and adjusting the graphics settings to the lowest possible doesn't change a thing
c) none of the other parts of the game seem to lag, and overall the game runs fluidly

When I play around with the mouse sensitivity settings (globally on my Mac and in the menu), it gets a little easier to control the pointer but not enough to play the game as intended.

If my description wasn't clear enough, I'm happy to record and upload a short video showing it.

Specs:
OS: Mojave 10.14
MacBook Air (early 2015)
Processor 1.6 GHz Intel Core i5 (I know this is lower than the "minimum required", but same is true for the Steam game "Don't starve together", which runs fine, and for the reasons mentioned above I don't think this is likely the issue)
Memory 8GB 1600 MHz DDR3
Graphics Intel HD Graphics 6000 1536 MB

This is the regular version of Viscera Cleanup Detail that I downloaded from Steam.

Thank you for your help!

Author:  Black Eagle [ Mon Nov 26, 2018 2:05 am ]
Post subject:  Re: Mouse "inertia" issue in VCD on Mac

Hmm. I'm afraid I'm really not sure why it would be doing this...

The only information I can find on the subject seems to suggest either unplugging your mouse(and other control peripherals), or plugging it into another USB port.

Other possible issues include, VSync being enabled, or drivers being out of date.

I can't say what exactly is the cause, as it's a common issue various games seem to have.
Odd that it happens in VCD. I'm not sure what makes it different. Even weirder it only happens in the menus... :-\
I don't think it's anything we've done. More likely an issue with the engine itself or its processing being incompatible with your system's unique setup.

Try those things, and if that doesn't help I'll see if I can dig even deeper into the problem. :think:

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/